IonCube Loader

IonCube Loader jest rozszerzeniem dla PHP, który dekoduje zaszyfrowane pliki PHP w czasie wykonywania, czyli jego zadaniem jest odkodowywanie skryptów, które wcześniej zostały zakodowane IonCube PHP Encoder

Wymagania wersji Loader

Pamiętaj Aby uniknąć problemów, najlepiej zawsze mieć zainstalowaną najnowszą wersję Ioncube Loader
Informacje o najnowszych Loaderach zawsze znajdziesz na stronie producenta

Tabele kompatybilności

Poniżej zamieszcamy tabele kompatybilności modułów i ich wymagania, wraz z datami, do których obowiązują.

Każdy moduł jest indywidualnie dostosowywany do wersji prestashop, aby sprawdzić, czy moduł będzie działał na konkretnej wersji Prestashop, prosimy o sprawdzenie tej informacji liście modułów

Obecna tabela kompatybilności modułów

Poniższa tabela obowiązuje do przełomu lipca/sierpnia 2018

Moduł Wersja PHP Minimalna wersja IonCube Wersja Encodera
php53 PHP 5.3 - PHP 5.6 4.7+ 8
php54 PHP 5.4 - PHP 5.6 5.0+ 9
php56_php70 PHP 5.6 - PHP 7.0 10.0+ 10
php71 PHP 7.1 10.0+ 10
  • W niektórych modułach już od pewnego czasu nie obsługujemy php 5.3

Od przełomu lipca/sierpnia 2018 publikację naszych modułów zgodnie z poniższą tabelą

Moduł Wersja PHP Minimalna wersja IonCube Wersja Encodera
php53 PHP 5.3 - PHP 5.6 wycofane wycofane
php54 PHP 5.4 - PHP 5.6 wycofane wycofane
php56_php70 PHP 5.6 - PHP 7.0 10.2.2 10.2
php71 PHP 7.1 10.2.2 10.2
php72 PHP 7.2 10.2.2 10.2


Jesteśmy obecnie w fazie testów i w zależności od ich wyników, istnieje duże prawdopdobieńśtwo, iż powstanie tylko 1 wersja, która będzie kompatybilna ze wszystkimi wersjami PHP.
Wymagana wersja IonCube loader dla tego rozwiązania to 10.2.2

Aktualizacja Loader'ów jest wymagana, aby móc bezproblemowo aktualizować moduły do najnowszych wersji. W przypadku aktualizacji modułu i nie zaktualizowania dodatku IonCube laoder, moduł wyświetli komunikat o wymaganej aktualizacji.

Aktualizacja IonCube Loader

Aktualizacji modułu IonCube Loader może dokonać tylko i wyłącznie administrator serwera / firma hostingowa. Prosimy kierować prośby o aktualizację do administratora.

Jak poinformować administratora

Poniżej zamieszczamy przykładową wiadomość, która może zostać wysłana do administratora / firmy hostingowej.

Dzień Dobry,

Serdecznie prosimy o informacje o możliwość zainstalowania i/lub aktualizacji IonCube Loader do wersji 10.2.2 na naszym hostingu.
Wersja ta wyjdzie między 18 a 22 czerwca 2018

Szczegółowe informacje czego potrzebujemy, producenci oprogramowania którego używamy ogłosili na: http://docs.seigi.eu
Informacje dla administratorów hostingu można zobaczyć tutaj

Serdecznie pozdrawiamy

Dlaczego przestajemy wspierać te wersje?

Jesteśmy zwolennikami szybszego i bezpieczniejszego internetu. W związku z tym, tak jak programiści tworzący PHP zakończyli support dla starszych wersji PHP, tak samo i my nie chcemy wspierać oprogramowania, które odeszło do lamusa i nie jest już bezpieczne.

Wersja PHP data końca wsparcia łatek bezpieczeńśtwa przez twórców
PHP 5.2 6 styczeń 2011
PHP 5.3 14 sierpień 2014
PHP 5.4 3 wrzesień 2015
PHP 5.5 21 lipiec 2016
PHP 5.6 31 grudzień 2018
PHP 7.0 3 grudzień 2018