Błąd: Error decode w module

Objawy

Podczas próby uruchomienia modułu lub wygenerowania pliku XML może pojawić się komunikat błędu podobny do poniższego:

Błąd połączenie z systemem licencji  
Wystąpił problem z połączeniem z serwerem licencji. Aby spróbować ponownie  
pobrać plik licencji, prosimy kliknąć tutaj: Pobierz Aktualną licencję z serwera

Auto-aktualizacja - włączona (ON)  
Komunikat błędu: Plik licencji nie jest prawidłowy (error: decode)

Testing seigi.eu / IP: 185.242.134.25: Connection OK  
Testing s1.license.seigi.eu / IP: 31.186.82.113: Connection OK  
Testing s2.license.seigi.eu / IP: 185.242.134.25: Connection OK  
Testing s3.license.seigi.eu / IP: 77.79.227.183: Connection OK  
Testing s4.license.seigi.eu / IP: 185.15.0.191: Connection OK  

Przyczyny

Błąd decode oznacza, że plik licencji nie mógł zostać prawidłowo odczytany lub zdekodowany. Najczęstsze przyczyny:

  1. Uszkodzony plik licencji – mógł zostać zmodyfikowany lub usunięty przez oprogramowanie zewnętrzne (np. antywirus, zapora, system backupowy).
  2. Tymczasowy problem z połączeniem z serwerem licencji – w momencie pobierania pliku wystąpiła przerwa w dostępie do internetu lub ograniczenie sieciowe.
  3. Stara wersja modułu – w wersjach starszych niż 4.32.4 problem mógł występować częściej z powodu braku mechanizmów zabezpieczających przed błędnym zapisaniem pliku.

Rozwiązanie

Krok 1: Usuń uszkodzony plik licencji

Ręcznie usuń plik licencji:

modules/{nazwa_modulu}/cache/{nazwa_modulu}.lic

Po jego usunięciu wejdź do modułu w panelu administracyjnym i kliknij przycisk „Pobierz Aktualną licencję z serwera“.

Krok 2: Zaktualizuj moduł

Jeśli błąd nadal się powtarza, zaktualizuj moduł do najnowszej wersji dostępnej tutaj: https://seigi.eu/downloads/prestamodules/pricewars2/d/

Jeśli nie możesz zaktualizować do najnowszej wersji, upewnij się przynajmniej, że korzystasz z wersji minimum 4.32.4, w której rozwiązano znane problemy z obsługą pliku licencji.

Instrukcja aktualizacji: Nie trzeba odinstalowywać modułu – wystarczy pobrać najnowszą paczkę, a następnie wgrać ją przez panel admina PrestaShop. Pliki zostaną nadpisane.


Jeśli problem będzie się powtarzać pomimo wykonania powyższych kroków, prosimy o kontakt z pomocą techniczną SEIGI.